Resolved
Google rate limiting issues

Started
March 12, 2021 at 2:31 PM
Status
Resolved after about 2 hours

Impact

Partial outage
Affected
App
  • Resolved
    March 12, 2021 at 4:29 PM

    This issue appears to be resolved now. We will continue monitoring the system closely!

  • Monitoring
    March 12, 2021 at 4:01 PM

    API errors have subsided. Our background processing for event changes is still disabled until we can be confident it will not trigger more errors.

  • Investigating
    March 12, 2021 at 2:50 PM

    To help reduce our volume of API requests, we've temporarily disabled consuming webhook notifications of changes to calendar events. This means you move or cancel a SavvyCal event on your Google Calendar, that change may not propagate back to SavvyCal.

  • Investigating
    March 12, 2021 at 2:31 PM

    We are currently receiving intermittent rate limiting errors from Google when attempting to access their API. This may affect the accuracy of availability displayed on booking pages, calendar overlays, and the creation of calendar events. We are working to resolved this problem as quickly as possible.