Started over 1 year agoNovember 05, 2024Lasted about 4 hours3:387:56 PMUTC
Affected
App
Partial outage from 3:38 PM to 7:56 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
Out of the abundance of caution, user registration is still disabled while we test out our abuse prevention mechanisms.
Identified
UTC
Identified
UTC
Between the hours of ~4:40am and 9:30am (Central Time), emails that SavvyCal attempted to send to users were paused by our email sending provider. We are now processing the backlog of these delayed emails.
Investigating
UTC
Investigating
UTC
SavvyCal is experiencing a distributed attack from spammers seeking to abuse our email sending infrastructure. We are currently working to mitigate the attack and send emails that have been delayed.