All systems operational

SquadCast API is down

Resolved
Major outage
Started 3 months ago Lasted about 5 hours

Affected

Integrations
SquadCast
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We've confirmed with the SquadCast team their API is currently experiencing an outage. Unfortunately, customers with SquadCast connected to their SavvyCal account may have experienced a flood of sessions getting created in their SquadCast account, due to the retry logic on our end. Until we confirm a fix from the SquadCast team, we've fully disabled the integration on our side.