All systems operational

Errors fetching availability from Microsoft 365

Resolved
Partial outage
Started 12 months ago Lasted about 3 hours

Affected

Calendar Connections
Microsoft 365
Updates
  • Resolved
    Resolved

    The API seem to have returned to normal behavior. We'll keep an eye on monitoring and open a new incident if errors and timeouts spike again.

  • Monitoring
    Update

    Microsoft provided the following update:

    We've determined that impact associated with MO571683 and EX571516 has reoccurred and are investigating the cause. We'll be providing updates related to this event under MO572252 in the admin center.

    https://twitter.com/MSFT365Status/status/1665814515198435329

  • Monitoring
    Monitoring

    The Microsoft 365 API experienced an unreported outage spike earlier this morning: https://downdetector.com/status/microsoft-365/

    We are continuing to observe intermittent timeouts when attempting to query calendars for event data (and perform other operations).